Twitter Yeni API’sini Tanıttı, Mart 2013′e Kadar Geçmek Zorunlu

 > -

Twitter Yeni API’sini Tanıttı, Mart 2013′e Kadar Geçmek Zorunlu

Twitter Yeni API’sini Tanıttı, Mart 2013′e Kadar Geçmek Zorunlu

Geçen ay API’sinde değişiklik yapacağını duyuran Twitter bugün resmi olarak yeni versiyonu tanıttı ve “Geliştirici Kuralları”nı yayınladı.

Tüm Twitter ekosistemini yakından ilgilendiren bu değişikliklere dair en önemli noktalardan biri 5 mart 2013 tarihine kadar yeni versiyona geçme zorunluluğu. Bu tarihten itibaren v1.0 kullanımdan kalkacak.

6 aylık takvimin yanı sıra yeni v.1.1, geleneksel Twitter müşteri uygulamaları hazırlayan geliştiricilerin işini biraz zorlaştıracak gibi gözüküyor. Buna bir de Twitter’ın ekosisteminin iplerini daha sıkı tutma çabası ekleniyor. Geliştiricleri en çok endişelendiren konu Twitter’ın 100.000 kullanıcı limiti. Bu kurala göre 100.000 limitini geçen uygulama doğrudan Twitter’la çalışma hakkı kazanıyor. En başta üçüncü parti uygulamaları ve geliştiricilerini denetlemek amacıyla konulan kural geliştiricilerin elini kolunu bağlıyor.

Bugunkü blog postunda konuyla ilgili ”100.000 kullanıcı limiti sadece ana Twitter deneyimini yineleyen ufak bir müşteri kitlesi için geçerli. Daha büyük ekosistemdeki çoğunluğu oluşturan uygulamalar bu kurala tabi değil” açıklamasını yapılsa da aslında bahsi geçen kuralın uygulamaları desteklemek yerine kontrol altında tutmak için uygulandığı izlenimini engelleyemiyor.

API değişiklikleri geliştiricileri Twitter’ın programına uymaya zorluyor ve kısıtlamalar getiriyor. Öte yandan gelişticiler oldukça uzun süredir Twitter’ın uygulamaları daha sıkı kontol altına alma ve kısıtlama yönünde politikalar benimseyeceğini biliyorlardı.

Haberin Tamamı İçin:

BU İÇERİĞE EMOJİYLE TEPKİ VER!
Helal olsun!
Hoş değil!
Yerim!
Çok acı...
Yok artık!
Çok iyi!
Kızgın!
YORUMLAR İÇİN TIKLAYINIZ

Başlıklar

Twitter
Görüş Bildir